Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This smite pc incident has been resolved. #smitepc
Posted 9 months ago. Mar 26, 2017 - 21:03 EDT
Update
Investigating: We are currently investigating this Smite PC issue. #SmitePC
Posted 9 months ago. Mar 26, 2017 - 20:41 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 9 months ago. Mar 26, 2017 - 20:38 EDT
This incident affected: Smite PC - North America / Europe.