Restart of a component of Smite PC
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved#smite
Posted about 1 year ago. Mar 01, 2016 - 09:28 EST
Investigating
We will be restarting a component of Smite PC now, those of you in parties may need to reparty #smite
Posted about 1 year ago. Mar 01, 2016 - 09:23 EST