Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins on #Smite #PS4 have resumed.
Posted 11 months ago. Apr 21, 2016 - 18:26 EDT
Identified
We are currently working to resume the logins for #Smite on #PS4.
Posted 11 months ago. Apr 21, 2016 - 18:18 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 11 months ago. Apr 21, 2016 - 18:11 EDT