Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 08, 2017 - 22:05 EST
Update
We are currently looking into issues with Paladins PC. #PALADINS
Posted 9 months ago. Mar 08, 2017 - 20:58 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 9 months ago. Mar 08, 2017 - 20:36 EST
This incident affected: Paladins PC.