Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 01, 2017 - 01:48 EDT
Update
Resolved: This Smite PS4 incident has been resolved. #Smite PS4
Posted about 2 months ago. Feb 01, 2017 - 01:47 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted about 2 months ago. Jan 31, 2017 - 22:38 EDT
This incident affected: Smite PS4 - North America / Europe.