Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart of Paladins has been completed.
Posted 7 months ago. Apr 12, 2018 - 12:02 EDT
Identified
We have identified the issue with Paladins PC and will be performing an emergency restart momentarily to deploy a fix.
Posted 7 months ago. Apr 12, 2018 - 11:53 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 7 months ago. Apr 12, 2018 - 11:24 EDT