Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Emergency restart for #Smite #Xbox has been completed.
Posted 5 months ago. Jun 30, 2017 - 20:06 EDT
Monitoring
Emergency restart for #Smite #Xbox has been completed. We are monitoring the results.
Posted 5 months ago. Jun 30, 2017 - 20:02 EDT
Identified
We are performing an emergency restart of #Smite #Xbox. The game will be up shortly.
Posted 5 months ago. Jun 30, 2017 - 19:43 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 5 months ago. Jun 30, 2017 - 19:33 EDT
This incident affected: Smite Xbox - North America / Europe.