Smite XBox Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 9 days ago. Dec 05, 2018 - 06:25 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 9 days ago. Dec 05, 2018 - 05:57 EST
Investigating
We are currently investigating a login issue with #Smite #Xbox
Posted 9 days ago. Dec 05, 2018 - 05:45 EST
This incident affected: Smite (Smite Xbox).