Paladins PC Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue affecting #Paladins #PC Logins has been resolved and we are continuing to monitor.
Posted 14 days ago. Jun 09, 2018 - 15:47 EDT
Identified
We are currently experiencing issues with Steam. We are working on the situation.
Posted 14 days ago. Jun 09, 2018 - 15:00 EDT
This incident affected: Paladins (Paladins PC).