Smite PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Aug 15, 2018 - 03:34 EDT
Monitoring
Restart is complete. We will continue to monitor for any further issues.
Posted Aug 15, 2018 - 03:06 EDT
Investigating
We are performing an emergency restart for #Smite #PS4. Game will be back up soon.
Posted Aug 15, 2018 - 02:48 EDT
This incident affected: SMITE (SMITE PS4).