Smite PC NA Spectating Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This smite pc incident has been resolved. # smitepc
Posted 4 months ago. Feb 05, 2017 - 10:50 EST
Investigating
Smite PC users may experience issues with spectating, we are working to fix the issue ASAP.... Sorry for the inconvenience. # Smite PC
Posted 4 months ago. Feb 05, 2017 - 09:35 EST
This incident affected: Smite PC - North America / Europe.