Smite Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Mar 19, 2020 - 23:10 EDT
Monitoring
Logins have resumed. We will continue to monitor the situation.
Posted Mar 19, 2020 - 22:20 EDT
Identified
We have identified an issue that is affecting logins for Smite. We will have a fix shortly.
Posted Mar 19, 2020 - 22:13 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch).