Crossplay Matchmaking Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 09, 2021 - 20:46 EDT
Monitoring
The issue affecting matches across #Smite and #Paladins has been mitigated. We will continue to monitor.
Posted Apr 09, 2021 - 19:59 EDT
Investigating
We are currently investigating an issue effecting #Smite and #Paladins on all platforms.
Posted Apr 09, 2021 - 16:57 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic) and Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch, Paladins Epic).