We will be Limiting Logins on #Smite #Xbox
Incident Report for Hi-Rez Studios, Inc
Resolved
This has been resolved
Posted 5 months ago. Apr 06, 2017 - 14:41 EDT
Investigating
Logins will be limited temporarily.
Posted 5 months ago. Apr 06, 2017 - 13:14 EDT
This incident affected: Smite Xbox - North America / Europe.