Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
All environments have recovered; this issue is resolved.
Posted about 1 year ago. Apr 11, 2017 - 01:00 EDT
Identified
We have identified an issue with all Hirez Games. We are recovering. Degraded performance but back to normal soon.
Posted about 1 year ago. Apr 11, 2017 - 00:47 EDT
Investigating
Automated services have detected a possible data center issue that may impact all games. We are investigating. #SMITE #Paladins #Tribes
Posted about 1 year ago. Apr 11, 2017 - 00:28 EDT
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox), Smite (Smite PC, Smite PS4, Smite Xbox), Hand of the Gods (Hand of the Gods PC), Tribes Ascend (Tribes Ascend), and Hi-Rez Studios (Hi-Rez Public APIs).