PS4 products difficulty logging in
Incident Report for Hi-Rez Studios, Inc
Resolved
PSN services are reporting that they are fully functional. We are monitoring the results.
Posted 3 months ago. Aug 23, 2018 - 03:08 EDT
Update
We are seeing an increase in #PS4 users that are able to log in to our products, but store is still experiencing difficulties. We are continuing to monitor. https://status.playstation.com/
Posted 3 months ago. Aug 23, 2018 - 02:35 EDT
Monitoring
PSN is having issues, and as such, users of our #PS4 products could encounter difficulty logging in. We are continuing to monitor the situation. https://status.playstation.com/
Posted 3 months ago. Aug 23, 2018 - 01:13 EDT
This incident affected: Smite (Smite PS4), Hand of the Gods (Hand of the Gods PS4), and Paladins (Paladins PS4).