Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue effecting connectivity to our game services has been resolved, and connectivity has now been restored.
We apologize for the inconvenience.
Posted over 1 year ago. Jun 02, 2016 - 21:18 EDT
Identified
We are currently investigating an event which has effected connectivity to our game services.
We will keep you informed as we gain more information.
Posted over 1 year ago. Jun 02, 2016 - 21:09 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted over 1 year ago. Jun 02, 2016 - 21:03 EDT