Smite Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The incident with #Smite #PC and #Xbox has been resolved.
Posted 5 months ago. Jun 05, 2017 - 18:41 EDT
Monitoring
We are monitoring issues with #Smite #PC and #Xbox and #PS4
Posted 5 months ago. Jun 05, 2017 - 18:27 EDT
Identified
We have identified an issue with Smite. #Smite #PC #Xbox #PS4
Posted 5 months ago. Jun 05, 2017 - 18:24 EDT
This incident affected: Smite PC - North America / Europe and Smite Xbox - North America / Europe.