Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This incident with Smite PC has been resolved. #Smite
Posted 9 months ago. Sep 13, 2016 - 10:43 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 9 months ago. Sep 13, 2016 - 10:31 EDT