Xbox match server problems
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Jan 08, 2016 - 23:23 EST
Monitoring
Xbox logins are back on, we are monitoring #xbox #smite
Posted about 1 year ago. Jan 08, 2016 - 23:17 EST
Investigating
We are looking into problems with our match servers. Logins may be temporarily suspended for a few minutes #smite #xbox
Posted about 1 year ago. Jan 08, 2016 - 22:48 EST