Smite XBOX Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Feb 17, 2016 - 17:04 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Feb 17, 2016 - 17:00 EST