Smite PC Issue Detected
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Smite #PC has been resolved.
Posted 18 days ago. Jun 06, 2017 - 20:10 EDT
Monitoring
A fix has been implemented, and we are monitoring the results for #Smite #PC
Posted 18 days ago. Jun 06, 2017 - 19:10 EDT
Update
We are performing an emergency restart for #Smite #PC. The game will be up shortly.
Posted 18 days ago. Jun 06, 2017 - 18:51 EDT
Identified
We have identified an issue with #Smite #PC
Posted 18 days ago. Jun 06, 2017 - 18:47 EDT
This incident affected: Smite PC - North America / Europe.