Smite PC Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 17 days ago. Nov 27, 2018 - 07:05 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 17 days ago. Nov 27, 2018 - 06:28 EST
Update
We are performing an emergency restart.
Posted 17 days ago. Nov 27, 2018 - 06:18 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 17 days ago. Nov 27, 2018 - 06:10 EST
Investigating
We are currently looking at login issues with Smite PC.
Posted 17 days ago. Nov 27, 2018 - 06:01 EST
This incident affected: Smite (Smite PC).