Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 12, 2016 - 00:04 EST
Update
Possible network issues with our EU instance servers.
We are working to restore these services.
#SMITE
Posted almost 2 years ago. Feb 11, 2016 - 23:58 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted almost 2 years ago. Feb 11, 2016 - 23:51 EST