Smite Blitz Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Feb 25, 2020 - 16:35 EST
Update
We are continuing to investigate this issue.
Posted Feb 25, 2020 - 12:17 EST
Update
We will continue to monitor this
Posted Feb 25, 2020 - 07:42 EST
Investigating
We are aware of an issue that is preventing players from logging into Smite Blitz. This issue is currently under investigation, and we thank you for your patience as we work through this issue.
Posted Feb 21, 2020 - 21:30 EST
This incident affected: SMITE Blitz (SMITE Blitz Mobile).