Smite Xbox restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite Xbox restart has been completed #smitexbox
Posted 6 months ago. Jan 28, 2019 - 05:45 EST
Investigating
We are performing an emergency restart on Smite Xbox #smitexbox
Posted 6 months ago. Jan 28, 2019 - 05:32 EST
This incident affected: Smite (Smite Xbox).