Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE XBox is no longer experiencing login issues.
Posted 11 months ago. Apr 30, 2016 - 21:19 EDT
Monitoring
XBox Live is no longer reporting issues, but #SMITE XBox players are still being impacted; we are monitoring the situation and will advise when it is resolved.
Posted 11 months ago. Apr 30, 2016 - 20:31 EDT
Identified
XBox Live is experiencing issues that are impacting #SMITE XBox players:
https://support.xbox.com/en-US/xbox-live-status
http://downdetector.com/status/xbox-live
Posted 11 months ago. Apr 30, 2016 - 20:18 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 11 months ago. Apr 30, 2016 - 20:10 EDT