Paladins Switch Extended Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Nov 15, 2018 - 23:53 EST
Identified
We are still working on issues with the #Paladins #Switch 1.8 upgrade. We apologize for the inconvenience.
Posted Nov 15, 2018 - 11:22 EST
This incident affected: Paladins (Paladins Switch).