All games network issues
Incident Report for Hi-Rez Studios, Inc
Resolved
Xbox is now confirmed stable. If you have any issues do a full relogin. #smite
Posted over 1 year ago. Dec 24, 2015 - 17:23 EDT
Update
Xbox appears to be stable now - Enjoy your Christmas Eve! #Smite
Posted over 1 year ago. Dec 24, 2015 - 16:57 EDT
Investigating
We believe Smite PC and Paladins are now stable. Xbox is still not working
Posted over 1 year ago. Dec 24, 2015 - 12:51 EDT
Update
We are still unstable - restart of all environments in 10 minutes
Posted over 1 year ago. Dec 24, 2015 - 11:17 EDT
Monitoring
We have turned on all games but are monitoring closely to see if there are still problems #smite #paladins
Posted over 1 year ago. Dec 24, 2015 - 10:37 EDT
Update
We will be doing network maintenance again at 9:45am EST - All games including Smite PC will be coming down #Smite #Paladins
Posted over 1 year ago. Dec 24, 2015 - 09:29 EDT
Update
We are still investigating #smite #paladins
Posted over 1 year ago. Dec 24, 2015 - 08:26 EDT
Update
We are still tracing down the network problem - xbox will remain down until it is isolated.
Posted over 1 year ago. Dec 24, 2015 - 08:15 EDT
Update
We are still investigating #smite #paladins
Posted over 1 year ago. Dec 24, 2015 - 08:07 EDT
Update
We are still investigating
Posted over 1 year ago. Dec 24, 2015 - 08:07 EDT
Investigating
After our maintenance this morning Xbox and Paladins are still having issues. We are investigating #smite #paladins
Posted over 1 year ago. Dec 24, 2015 - 07:26 EDT