Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue with #Paladins #PC has been resolved.
Posted 10 months ago. Jan 12, 2018 - 00:45 EST
Monitoring
The emergency restart of #Paladins #PC has been completed. We are monitoring the results.
Posted 10 months ago. Jan 12, 2018 - 00:24 EST
Identified
We will be performing an emergency restart for #Paladins #PC. Game will be back up soon.
Posted 10 months ago. Jan 11, 2018 - 23:47 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 10 months ago. Jan 11, 2018 - 23:40 EST
This incident affected: Paladins (Paladins PC).