Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#PaladinsPC has recovered; we apologize for the inconvenience.
Posted about 1 month ago. Apr 19, 2017 - 17:36 EDT
Monitoring
We have identified and addressed an issue with #PaladinsPC; game is recovering; we are continuing to monitor
Posted about 1 month ago. Apr 19, 2017 - 17:24 EDT
Update
Investigating: We are currently investigating Paladins PC this issue. #paldinspc
Posted about 1 month ago. Apr 19, 2017 - 17:08 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 1 month ago. Apr 19, 2017 - 17:04 EDT
This incident affected: Paladins PC.