Smite Servers Down
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 18 days ago. Jun 05, 2018 - 11:54 EDT
Update
We are continuing to monitor for any further issues.
Posted 18 days ago. Jun 05, 2018 - 11:32 EDT
Update
We are continuing to monitor for any further issues.
Posted 18 days ago. Jun 05, 2018 - 11:12 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 18 days ago. Jun 05, 2018 - 10:56 EDT
Update
We are continuing to work on a fix for this issue.
Posted 18 days ago. Jun 05, 2018 - 10:50 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 18 days ago. Jun 05, 2018 - 10:50 EDT
This incident affected: Smite (Smite PC, Smite PS4, Smite Xbox).