Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Paladins #PC has been resolved.
Posted 7 days ago. Aug 10, 2017 - 17:42 EDT
Monitoring
Logins have resumed for #Paladins and we will continue to monitor closely
Posted 7 days ago. Aug 10, 2017 - 16:24 EDT
Identified
We will be limiting logins briefly for Paladins PC
Posted 7 days ago. Aug 10, 2017 - 16:04 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 7 days ago. Aug 10, 2017 - 15:59 EDT
This incident affected: Paladins PC.