Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 15, 2017 - 02:41 EST
Identified
We will be performing an emergency restart of #Smite on #PC, we apologize for the inconvenience.
Posted 5 months ago. Jan 15, 2017 - 02:16 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 5 months ago. Jan 15, 2017 - 02:12 EST
This incident affected: Smite PC - North America / Europe.