Smite PS4 and Xbox Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 8 days ago. Nov 09, 2018 - 13:00 EST
Monitoring
Restart has been finished. You may access the game now.
Posted 8 days ago. Nov 09, 2018 - 10:14 EST
Update
We are performing an emergency restart on Smite Xbox and PS4.
Posted 8 days ago. Nov 09, 2018 - 10:05 EST
Investigating
We are looking into the issues with #Smite #Xbox and #PS4
Posted 8 days ago. Nov 09, 2018 - 10:01 EST
This incident affected: Smite (Smite PS4, Smite Xbox).