Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We had a number of EU instances lose connection for a small amount of time.
Service has since been restored to these instances, and matches are launching normally.
#SMITE
Posted over 1 year ago. Feb 10, 2016 - 23:25 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted over 1 year ago. Feb 10, 2016 - 23:08 EST