Realm Royale Crossplay Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 20, 2020 - 11:49 EDT
Identified
The issue has been identified and a fix implemented.
Posted May 20, 2020 - 11:36 EDT
Investigating
We are currently investigating this issue.
Posted May 20, 2020 - 11:06 EDT
This incident affected: Realm Royale Reforged (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).