Hi-Rez Online Store Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The #Smite, #Paladins, #HotG #PC store issue has been resolved.
Posted 10 days ago. May 14, 2018 - 16:51 EDT
Monitoring
We hav identified and isolated the issue affecting #Smite, #Paladins, and #HotG #PC purchases. We are continuing to monitor.
Posted 10 days ago. May 14, 2018 - 16:10 EDT
Identified
We are currently working to resolve an issue with purchases that are impacting Smite PC/Hand of the Gods PC/ Paladins PC . During this time you may experience errors when trying to purchase gems or crystals.
Posted 10 days ago. May 14, 2018 - 14:43 EDT
This incident affected: Paladins (Paladins PC), Smite (Smite PC), and Hand of the Gods (Hand of the Gods PC).