Hand Of the Gods Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The Emergency Restart of Hand Of the Gods has been Completed.
Posted 2 months ago. Jun 10, 2017 - 12:30 EDT
Investigating
We are performing an emergency restart of #HandOftheGods
Posted 2 months ago. Jun 10, 2017 - 12:23 EDT
This incident affected: Smite Tactics.