Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 07:19 EDT
Investigating
Automated services have detected a possible data center issue that may impact all games. We are investigating. #SMITE #Paladins #Tribes
Posted Mar 12, 2020 - 04:13 EDT