Smite PC, Switch, & Xbox Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 months ago. Feb 11, 2019 - 23:43 EST
Update
Restart is complete, and logins have resumed.
Posted 2 months ago. Feb 11, 2019 - 17:33 EST
Update
The restart has been completed and we are closely monitoring the game.
Posted 2 months ago. Feb 11, 2019 - 17:33 EST
Update
We are performing another restart of #Smite on #PC #Xbox and #Switch momentarily.
Posted 2 months ago. Feb 11, 2019 - 17:19 EST
Monitoring
Restart has been completed and logins have resumed.
Posted 2 months ago. Feb 11, 2019 - 16:42 EST
Update
We are performing an emergency restart on Smite PC, Xbox & Switch
Posted 2 months ago. Feb 11, 2019 - 16:24 EST
Update
We are temporarily pausing logins while we investigate the issue.
Posted 2 months ago. Feb 11, 2019 - 16:18 EST
Investigating
We are investigating an issue with #Smite #PC, #Switch, & #Xbox logins.
Posted 2 months ago. Feb 11, 2019 - 16:15 EST
This incident affected: Smite (Smite PC, Smite Xbox).