Smite/Paladins/Realm Royale Xbox Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue has been resolved.
Posted 6 months ago. Jan 30, 2019 - 15:23 EST
Monitoring
Players may be experiencing issues with #Smite, #Paladins, and/or #RealmRoyale #Xbox due to ongoing Xbox Live issues.

More information can be found here: https://support.xbox.com/en-US/xbox-live-status
Posted 6 months ago. Jan 30, 2019 - 13:24 EST
This incident affected: Smite (Smite Xbox), Paladins (Paladins Xbox), and Realm Royale (Realm Royale Xbox).