Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident with #Paladins PC has been resolved
Posted Aug 15, 2017 - 09:36 EDT
Monitoring
Logins have resumed for #Paladins PC
Posted Aug 15, 2017 - 09:21 EDT
Identified
We will be limiting logins briefly for #Paladins PC
Posted Aug 15, 2017 - 08:54 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted Aug 15, 2017 - 08:47 EDT