Paladins Cross Play Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 16 days ago. Apr 07, 2019 - 15:04 EDT
Monitoring
Restart has been completed, we are continuing to monitor.
Posted 16 days ago. Apr 07, 2019 - 14:09 EDT
Investigating
We are performing an emergency restart on Paladins PC, Xbox and Switch.
Posted 16 days ago. Apr 07, 2019 - 13:54 EDT
This incident affected: Paladins (Paladins PC, Paladins Xbox, Paladins Switch).