Xbox login problems
Incident Report for Hi-Rez Studios, Inc
Resolved
smite xbox is back up #smite #xbox
Posted over 1 year ago. Jan 08, 2016 - 19:10 EST
Monitoring
We have restarted and are monitoring live XBOX #smite #xbox
Posted over 1 year ago. Jan 08, 2016 - 19:00 EST
Investigating
We have an unexpected problem with Xbox servers #smite #xbox
Posted over 1 year ago. Jan 08, 2016 - 18:33 EST