Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Paladins is back up and hosting matches
Posted 11 months ago. Sep 26, 2016 - 14:16 EDT
Identified
We are currently working to restore services for #Paladins.
We apologize for the inconvenience.
Posted 11 months ago. Sep 26, 2016 - 14:06 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 11 months ago. Sep 26, 2016 - 13:52 EDT