Smite Match Making Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 29, 2020 - 21:21 EDT
Monitoring
Logins have resumed. We will be monitoring the results.
Posted May 29, 2020 - 15:42 EDT
Identified
We will temporarily be limiting logins for Smite to address the issues with matchmaking. Some game services may be unavailable during this time.
Posted May 29, 2020 - 15:35 EDT
Investigating
We are currently investigating an issue that is affecting matchmaking for Smite.
Posted May 29, 2020 - 15:33 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch).