Realm Royale Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 14, 2020 - 02:12 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 14, 2020 - 01:40 EDT
Investigating
We will be performing an emergency restart of #RealmRoyale. The game will be back shortly.
Posted May 13, 2020 - 23:36 EDT
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).