Realm Royale Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #RealmRoyale incident has been resolved.
Posted Feb 22, 2021 - 14:37 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 22, 2021 - 14:04 EST
Update
We are limiting logins for #RealmRoyale at this time while we further investigate this issue.
Posted Feb 22, 2021 - 13:49 EST
Update
We are continuing to investigate this issue.
Posted Feb 22, 2021 - 13:43 EST
Investigating
We are currently investigating this issue.
Posted Feb 22, 2021 - 13:42 EST
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).