#Paladins #PC Limited log ins
Incident Report for Hi-Rez Studios, Inc
Resolved
Normal log ins for #Paladins #PC have resumed
Posted about 2 months ago. Jul 05, 2017 - 12:50 EDT
Identified
We will be limiting log ins for #Paladins #PC momentarily
Posted about 2 months ago. Jul 05, 2017 - 12:44 EDT
This incident affected: Paladins PC.